Trouble getting lights to work in 3D View

You are here

4 posts / 0 new
Last post
yogi36
yogi36's picture
Trouble getting lights to work in 3D View
SoftPlan Version:
2014

Ok, I am back again with another easy question...

 

I would love to get my light fixtures to actually illuminate when I am view them in the 3D mode. I have tried to edit the related settings but I have yet to get them to "turn on" 

 

Any thoughts? I assume this is possible right? 

 

 

Thanks Again, 

Ryan

pdfrank
pdfrank's picture
Hi Ryan,

Hi Ryan,

These settings work for me. See pic and recommended settings. The key seems to be placing a ckeckmark in the "Custom" box. BTW you get to this this dialog box by clicking on "Options" and then "Mode Options" and then "Lighting" in SoftView mode

Bill Wimberley
Bill Wimberley's picture
3D Lights

Ryan, there are a number of things that affect whether or not lights show in 3D.

First of all, a "light" has to be built into the electrical symbol in the first place. If you are using the light symbols that came with SoftPlan the lights should be in the symbol. If you created the electrical symbol yourself then the light is most likely not built in unless you knew to add the lights before creating the symbol. You can verify whether or not a symbol has a light by editing the symbol. If a Light tab exists then there is a light. If not there is not. You can also check by looking at the 3D mode. This will be one of the modes like Drawing, Electrical, etc. Electrical symbols that contain lights will show a little differently in 3D mode. For instance they may have a blue center with a yellow halo or a rectangle that radiates out from the symbol.

Another thing is that the light has to be turned "on". If you edit the electrical symbol and click on the Lights tab there will be a check box that must be turned "on". You will also see a Custom box that if checked allows you to modify the settings for the light. You could conceivably have the light turned on but the brightness set at 0 and the light wouldn't show in 3D. Additionally there is a "Distance" setting that determines how far the light will shine before it fades. And a Decay setting that sets how quickly the light fades.

And as Phillip pointed out you must have "Turn Off Lights in Symbols" unchecked in the Lighting section of the render mode in which you are viewing the model.

All of these settings affect lights in 3D. So any one of them could cause lights to not show in 3D.

 

Bill is the owner and maintainer of SoftPlanTuts.com

yogi36
yogi36's picture
Resolved

Once again y'all were able to get me going. I wish I could by coffee for everyone. 

 

Much Thanks, 

Ryan