Electrical Symbol Pen assignment

You are here

7 posts / 0 new
Last post
DamonB
DamonB's picture
Electrical Symbol Pen assignment

Ok so I created a bunch of new electrical symbols. I would like all electrical symbols to be pen 3. I adjusted the pen assignment for electrical symbols and connections in system and drawing options to pen 3. However the system elect. symbols are still pen 2 and the new ones I created are pen 3(as per the lines that created them). I did open a new empty drawing to test this as well. My understanding from my manual is that I can globally change pens for a category of items through system option pen setup. Is that not the case?

 

Thanks

Bill Wimberley
Bill Wimberley's picture
Electrical Symbol Pen assignment

Hey Damon, I tried changing the electrical symbols to pen 3 and it worked fine.

Remember that System Options and Drawing Options are different. System Options affect any new drawings you create and Drawing Options only affect the currently open drawing.

So to make this work for all of your New drawings you would change the Electrical Symbols pen style to Pen 3 in System Options. And to make the change for any drawings that have already been created make the pen assignment in the current drawings Drawing Options.

Also, make sure that any electrical symbols in your drawing do not have a check next to Pen. Edit the electrical symbol and look at Pen in the Symbol tab of the edit dialog box. Placing a check next to Pen in a symbol overrides the Drawing Options settings.

One final thing to look at is the Pen Styles. If you changed the Pen Style for Pen 3 in your test drawing but did not make the same change in your System Options Pen Styles then only the test drawing would have the changed Pen Style.

Please let me know if this solves your problem. If not then please attach a drawing with some of your electrical symbols so I can take a look at it.

 

Bill is the owner and maintainer of SoftPlanTuts.com

DamonB
DamonB's picture
Electrical Symbol Pen Assignment

Bill,

As far as I can tell my system options and drawing options line up (hence why I created a new empty drawing) all the symbols think they are pen 3 in properties however some still print darker than others even though the pen is not checked off in properties and overridden for any of them. I'm really baffled as to what is going on. I have attached the drawing if you have time to take a look.

 

Thanks 

AttachmentSize
Binary Data Electrical Sample.spd50.89 KB
Bill Wimberley
Bill Wimberley's picture
Electrical Symbol Pen Assignment

That's pretty odd. I printed the file you attached to PDF and everything appears to be Pen 3. I even changed the color assignment of Pen 3 to blue just to verify that it actually was Pen 3 that was printing. See attached below.

The only thing I saw funky was your 220v outlet. The top of the 22 printed black and was not sharp.

Perhaps try creating a new Project and insert some electrical symbols to see what happens in a new Project.

 

DamonB
DamonB's picture
Electrical Symbol Pen assignment

Bill,

I sent this entire project off to SoftPlan as they also can't make heads or tales of this at all.

 

Thanks for your help. 

DamonB
DamonB's picture
Electrical Symbol Pen assignment

Bill,

Funny solution.

I sent it off to Nathan at SoftPlan and he also couldn't get it to print with the wrong pen.

He suggested installing the latest update (which I needed) and it fixed it.

 

Thanks for all the help

Bill Wimberley
Bill Wimberley's picture
DamonB's picture Electrical Symbol Pen assignment

Guess that explains why I couldn't get the same results as you. I already had the latest patch when I was checking out your symbols. Glad you finally got it resolved :)